aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/hardening.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/hardening.mk b/include/hardening.mk
index 06a61789ef..42ce1f56b5 100644
--- a/include/hardening.mk
+++ b/include/hardening.mk
@@ -18,7 +18,7 @@ ifdef CONFIG_PKG_CHECK_FORMAT_SECURITY
endif
ifdef CONFIG_PKG_ASLR_PIE
ifeq ($(strip $(PKG_ASLR_PIE)),1)
- TARGET_CFLAGS += -fPIC
+ TARGET_CFLAGS += $(FPIC)
TARGET_LDFLAGS += -specs=$(INCLUDE_DIR)/hardened-ld-pie.specs
endif
endif