aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/prereq.mk12
1 files changed, 3 insertions, 9 deletions
diff --git a/include/prereq.mk b/include/prereq.mk
index 5cb1102182..9f1ff70eed 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -107,15 +107,9 @@ define SetupHostCommand
bin="$$$$$$$$(command -v "$$$$$$$${cmd%% *}")"; \
if [ -x "$$$$$$$$bin" ] && eval "$$$$$$$$cmd" >/dev/null 2>/dev/null; then \
case "$$$$$$$$(ls -dl -- $(STAGING_DIR_HOST)/bin/$(strip $(1)))" in \
- *" -> $$$$$$$$bin"*) \
- [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
- ;; \
- "-"*) \
- [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
- ;; \
- *" -> /"*) \
- ;; \
- *" -> "*) \
+ "-"* | \
+ *" -> $$$$$$$$bin"* | \
+ *" -> "[!/]*) \
[ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
;; \
esac; \