aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/download.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/download.mk b/include/download.mk
index 76bd374cf7..9ff71540f7 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -18,6 +18,9 @@ endif
DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
+# Export options for download.pl
+export DOWNLOAD_CHECK_CERTIFICATE:=$(CONFIG_DOWNLOAD_CHECK_CERTIFICATE)
+
define dl_method_git
$(if $(filter https://github.com/% git://github.com/%,$(1)),github_archive,git)
endef