aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 6b4bc4945c..492e6933f1 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -218,6 +218,11 @@ define Build/copy-file
cat "$(1)" > "$@"
endef
+define Build/edimax-header
+ $(STAGING_DIR_HOST)/bin/mkedimaximg -i $@ -o $@.new $(1)
+ @mv $@.new $@
+endef
+
define Build/elecom-product-header
$(eval product=$(word 1,$(1)))
$(eval fw=$(if $(word 2,$(1)),$(word 2,$(1)),$@))