aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/u-boot.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/u-boot.mk b/include/u-boot.mk
index 8945e8e2b8..2b8106410f 100644
--- a/include/u-boot.mk
+++ b/include/u-boot.mk
@@ -83,6 +83,9 @@ endef
define Build/Configure/U-Boot
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIGURE_VARS) $(UBOOT_CONFIG)_config
+ $(if $(strip $(UBOOT_CUSTOMIZE_CONFIG)),
+ $(PKG_BUILD_DIR)/scripts/config --file $(PKG_BUILD_DIR)/.config $(UBOOT_CUSTOMIZE_CONFIG)
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIGURE_VARS) oldconfig)
endef
DTC=$(wildcard $(LINUX_DIR)/scripts/dtc/dtc)