aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 376553b8d2..402e3d71ed 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -112,6 +112,15 @@ define Build/append-squashfs-fakeroot-be
cat $@.fakesquashfs >> $@
endef
+define Build/append-squashfs4-fakeroot
+ rm -rf $@.fakefs $@.fakesquashfs
+ mkdir $@.fakefs
+ $(STAGING_DIR_HOST)/bin/mksquashfs4 \
+ $@.fakefs $@.fakesquashfs \
+ -nopad -noappend -root-owned
+ cat $@.fakesquashfs >> $@
+endef
+
define Build/append-string
echo -n $(1) >> $@
endef
@@ -376,6 +385,19 @@ define Build/netgear-dni
mv $@.new $@
endef
+define Build/netgear-encrypted-factory
+ $(TOPDIR)/scripts/netgear-encrypted-factory.py \
+ --input-file $@ \
+ --output-file $@ \
+ --model $(NETGEAR_ENC_MODEL) \
+ --region $(NETGEAR_ENC_REGION) \
+ --version V1.0.0.0.$(VERSION_DIST).$(firstword $(subst -, ,$(REVISION))) \
+ --encryption-block-size 0x20000 \
+ --openssl-bin "$(STAGING_DIR_HOST)/bin/openssl" \
+ --key 6865392d342b4d212964363d6d7e7765312c7132613364316e26322a5a5e2538 \
+ --iv 4a253169516c38243d6c6d2d3b384145
+endef
+
define Build/openmesh-image
$(TOPDIR)/scripts/om-fwupgradecfg-gen.sh \
"$(call param_get_default,ce_type,$(1),$(DEVICE_NAME))" \