aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 7b345ebbaa..8fae92ab97 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -204,17 +204,19 @@ $(eval $(call SetupHostCommand,which,Please install 'which', \
/bin/which which, \
which which))
-$(eval $(call RequireCHeader,argp.h, \
+ifeq ($(HOST_OS),Linux)
+ $(eval $(call RequireCHeader,argp.h, \
Missing argp.h Please install the argp-standalone package if musl libc))
-$(eval $(call RequireCHeader,fts.h, \
+ $(eval $(call RequireCHeader,fts.h, \
Missing fts.h Please install the musl-fts-dev package if musl libc))
-$(eval $(call RequireCHeader,obstack.h, \
+ $(eval $(call RequireCHeader,obstack.h, \
Missing obstack.h Please install the musl-obstack-dev package if musl libc))
-$(eval $(call RequireCHeader,libintl.h, \
+ $(eval $(call RequireCHeader,libintl.h, \
Missing libintl.h Please install the musl-libintl package if musl libc))
+endif
$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
mkdir -p $(dir $@)