aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 91865e1e7e..23c7bd6133 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -27,6 +27,15 @@ define Build/append-kernel
dd if=$(IMAGE_KERNEL) >> $@
endef
+define Build/package-kernel-ubifs
+ mkdir $@.kernelubifs
+ cp $@ $@.kernelubifs/kernel
+ $(STAGING_DIR_HOST)/bin/mkfs.ubifs \
+ $(KERNEL_UBIFS_OPTS) \
+ -r $@.kernelubifs $@
+ rm -r $@.kernelubifs
+endef
+
define Build/append-image
dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) >> $@
endef