aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/kernel-version.mk7
-rw-r--r--include/target.mk4
2 files changed, 11 insertions, 0 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 81ec2bd252..c978294ecf 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -2,6 +2,10 @@
LINUX_RELEASE?=1
+ifdef CONFIG_TESTING_KERNEL
+ KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
+endif
+
LINUX_VERSION-4.9 = .172
LINUX_VERSION-4.14 = .115
LINUX_VERSION-4.19 = .38
@@ -23,6 +27,9 @@ else
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
endif
+ifdef KERNEL_TESTING_PATCHVER
+ LINUX_TESTING_VERSION:=$(KERNEL_TESTING_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_TESTING_PATCHVER)))
+endif
endif
split_version=$(subst ., ,$(1))
diff --git a/include/target.mk b/include/target.mk
index d24bb9cd11..4f3bd43e6c 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -225,6 +225,9 @@ ifeq ($(DUMP),1)
.SILENT: $(TMP_CONFIG)
.PRECIOUS: $(TMP_CONFIG)
+ ifdef KERNEL_TESTING_PATCHVER
+ FEATURES += testing-kernel
+ endif
ifneq ($(CONFIG_OF),)
FEATURES += dt
endif
@@ -283,6 +286,7 @@ define BuildTargets/DumpCurrent
echo 'Target-Optimization: $(if $(CFLAGS),$(CFLAGS),$(DEFAULT_CFLAGS))'; \
echo 'CPU-Type: $(CPU_TYPE)$(if $(CPU_SUBTYPE),+$(CPU_SUBTYPE))'; \
echo 'Linux-Version: $(LINUX_VERSION)'; \
+ $(if $(LINUX_TESTING_VERSION),echo 'Linux-Testing-Version: $(LINUX_TESTING_VERSION)';) \
echo 'Linux-Release: $(LINUX_RELEASE)'; \
echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \
$(if $(SUBTARGET),,$(if $(DEFAULT_SUBTARGET), echo 'Default-Subtarget: $(DEFAULT_SUBTARGET)'; )) \