aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/kernel-build.mk2
-rw-r--r--include/toplevel.mk4
2 files changed, 5 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 32c91a5b83..9dfb19ccc7 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -157,7 +157,7 @@ define BuildKernel
compile: $(LINUX_DIR)/.modules
$(MAKE) -C image compile TARGET_BUILD=
- oldconfig menuconfig nconfig: $(STAMP_PREPARED) $(STAMP_CHECKED) FORCE
+ oldconfig menuconfig nconfig xconfig: $(STAMP_PREPARED) $(STAMP_CHECKED) FORCE
rm -f $(LINUX_DIR)/.config.prev
rm -f $(STAMP_CONFIGURED)
$(LINUX_RECONF_CMD) > $(LINUX_DIR)/.config
diff --git a/include/toplevel.mk b/include/toplevel.mk
index ba59595764..8564a4de73 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -169,6 +169,7 @@ kernel_oldconfig: prepare_kernel_conf
ifneq ($(DISTRO_PKG_CONFIG),)
kernel_menuconfig: export PATH:=$(dir $(DISTRO_PKG_CONFIG)):$(PATH)
kernel_nconfig: export PATH:=$(dir $(DISTRO_PKG_CONFIG)):$(PATH)
+kernel_xconfig: export PATH:=$(dir $(DISTRO_PKG_CONFIG)):$(PATH)
endif
kernel_menuconfig: prepare_kernel_conf
$(_SINGLE)$(NO_TRACE_MAKE) -C target/linux menuconfig
@@ -176,6 +177,9 @@ kernel_menuconfig: prepare_kernel_conf
kernel_nconfig: prepare_kernel_conf
$(_SINGLE)$(NO_TRACE_MAKE) -C target/linux nconfig
+kernel_xconfig: prepare_kernel_conf
+ $(_SINGLE)$(NO_TRACE_MAKE) -C target/linux xconfig
+
staging_dir/host/.prereq-build: include/prereq-build.mk
mkdir -p tmp
@$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \