aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/rootfs.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index f2d2494ae2..b6775c7e15 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -99,4 +99,5 @@ define prepare_rootfs
rm -rf $(1)/boot
$(call clean_ipkg,$(1))
$(call mklibs,$(1))
+ $(if $(SOURCE_DATE_EPOCH),find $(1)/ -mindepth 1 -execdir touch -hcd "@$(SOURCE_DATE_EPOCH)" "{}" +)
endef