aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 083a389031..a7acd0ee67 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -190,3 +190,8 @@ metadata_json = \
define Build/append-metadata
$(if $(SUPPORTED_DEVICES),echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
endef
+
+define Build/kernel2minor
+ kernel2minor -k $@ -r $@.new $(1)
+ mv $@.new $@
+endef