aboutsummaryrefslogtreecommitdiffstats
path: root/include/verbose.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/verbose.mk')
-rw-r--r--include/verbose.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/include/verbose.mk b/include/verbose.mk
index 3ecf842d11..4487a207e8 100644
--- a/include/verbose.mk
+++ b/include/verbose.mk
@@ -29,15 +29,15 @@ ifeq ($(IS_TTY),1)
endif
endif
+define ERROR_MESSAGE
+ printf "$(_R)%s$(_N)\n" "$(1)" >&8
+endef
+
ifeq ($(findstring s,$(OPENWRT_VERBOSE)),)
define MESSAGE
printf "$(_Y)%s$(_N)\n" "$(1)" >&8
endef
- define ERROR_MESSAGE
- printf "$(_R)%s$(_N)\n" "$(1)" >&8
- endef
-
ifeq ($(QUIET),1)
ifneq ($(CURDIR),$(TOPDIR))
_DIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
@@ -60,5 +60,4 @@ else
define MESSAGE
printf "%s\n" "$(1)"
endef
- ERROR_MESSAGE=$(MESSAGE)
endif