aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index a2c8b7bdbf..708ba395c6 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -68,7 +68,7 @@ endif
target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
ifeq ($(DUMP),)
- PLATFORM_DIR:=$(TOPDIR)/target/linux/$(BOARD)
+ PLATFORM_DIR:=$(firstword $(wildcard $(TOPDIR)/target/linux/feeds/$(BOARD) $(TOPDIR)/target/linux/$(BOARD)))
SUBTARGET:=$(strip $(foreach subdir,$(patsubst $(PLATFORM_DIR)/%/target.mk,%,$(wildcard $(PLATFORM_DIR)/*/target.mk)),$(if $(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(subdir))),$(subdir))))
else
PLATFORM_DIR:=${CURDIR}