aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index 31ce592c8b..a2e76f8149 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -15,7 +15,6 @@ DEVICE_TYPE?=router
# Default packages - the really basic set
DEFAULT_PACKAGES:=\
base-files \
- busybox \
ca-bundle \
dropbear \
fstools \
@@ -30,6 +29,13 @@ DEFAULT_PACKAGES:=\
uclient-fetch \
urandom-seed \
urngd
+
+ifneq ($(CONFIG_SELINUX),)
+DEFAULT_PACKAGES+=busybox-selinux procd-selinux
+else
+DEFAULT_PACKAGES+=busybox procd
+endif
+
# For the basic set
DEFAULT_PACKAGES.basic:=
# For nas targets