aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index d4950e5b2b..8d5ae1e1d3 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -51,6 +51,10 @@ else
endif
endif
+ifneq ($(filter 3.18 4.4 4.9,$(KERNEL_PATCHVER)),)
+ DEFAULT_PACKAGES.router:=$(filter-out kmod-ipt-offload,$(DEFAULT_PACKAGES.router))
+endif
+
# Add device specific packages (here below to allow device type set from subtarget)
DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))