aboutsummaryrefslogtreecommitdiffstats
path: root/include/rootfs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/rootfs.mk')
-rw-r--r--include/rootfs.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index a3a08c2851..bf26dd2415 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -63,9 +63,9 @@ ifdef CONFIG_CLEAN_IPKG
endif
define prepare_rootfs
- @if [ -d $(TOPDIR)/files ]; then \
- $(call file_copy,$(TOPDIR)/files/.,$(1)); \
- fi
+ $(if $(2),@if [ -d '$(2)' ]; then \
+ $(call file_copy,$(2)/.,$(1)); \
+ fi)
@mkdir -p $(1)/etc/rc.d
@mkdir -p $(1)/var/lock
@( \