aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 03d19bf39c..7f525e2e93 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -8,6 +8,11 @@ ifeq ($(TARGET_BUILD),1)
PKG_BUILD_DIR:=$(LINUX_DIR)
endif
+ifneq ($(filter host-refresh refresh,$(MAKECMDGOALS)),)
+ override QUILT=1
+ override HOST_QUILT=1
+endif
+
ifneq ($(PKG_BUILD_DIR),)
QUILT?=$(if $(wildcard $(PKG_BUILD_DIR)/.quilt_used),y)
ifneq ($(QUILT),)
@@ -36,11 +41,6 @@ FILES_DIR?=./files
HOST_PATCH_DIR?=$(PATCH_DIR)
HOST_FILES_DIR?=$(FILES_DIR)
-ifneq ($(filter host-refresh refresh,$(MAKECMDGOALS)),)
- override QUILT=1
- override HOST_QUILT=1
-endif
-
QUILT_CMD:=quilt --quiltrc=-
define filter_series