aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/prereq.mk')
-rw-r--r--include/prereq.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq.mk b/include/prereq.mk
index 45c84e984c..ada11a8701 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -110,6 +110,10 @@ define SetupHostCommand
*" -> $$$$$$$$bin"*) \
[ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
;; \
+ "-"*) \
+ find "$(STAGING_DIR_HOST)/stamp" | grep $(strip $(1)) && \
+ [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
+ ;; \
esac; \
ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \
exit 0; \