aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 600cf1d771..a698deec3c 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -170,9 +170,7 @@ define BuildKernel
) \
YACC=$(STAGING_DIR_HOST)/bin/bison \
$$@
- $(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config | \
- grep -vE '(CONFIG_CC_(HAS_ASM_GOTO|IS_GCC|IS_CLANG)|GCC_VERSION)=' \
- > $(LINUX_RECONFIG_TARGET)
+ $(call LINUX_RECONF_DIFF,$(LINUX_DIR)/.config) > $(LINUX_RECONFIG_TARGET)
install: $(LINUX_DIR)/.image
+$(MAKE) -C image compile install TARGET_BUILD=