aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index 96a8892115..f4d0a157cd 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -440,7 +440,7 @@ define Device/Build/dtb
ifndef BUILD_DTS_$(1)
BUILD_DTS_$(1) := 1
$(KDIR)/image-$(1).dtb: FORCE
- $(call Image/BuildDTB,$(strip $(2))/$(1).dts,$$@)
+ $(call Image/BuildDTB,$(strip $(2))/$(strip $(3)).dts,$$@)
image_prepare: $(KDIR)/image-$(1).dtb
endif
@@ -450,8 +450,9 @@ endif
define Device/Build/kernel
$$(eval $$(foreach dts,$$(DEVICE_DTS), \
- $$(call Device/Build/dtb,$$(dts), \
- $$(if $$(DEVICE_DTS_DIR),$$(DEVICE_DTS_DIR),$$(DTS_DIR)) \
+ $$(call Device/Build/dtb,$$(notdir $$(dts)), \
+ $$(if $$(DEVICE_DTS_DIR),$$(DEVICE_DTS_DIR),$$(DTS_DIR)), \
+ $$(dts) \
) \
))