aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 47d9d1ab88..0c13f30fef 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -126,6 +126,13 @@ define Build/append-string
echo -n $(1) >> $@
endef
+define Build/append-md5sum-ascii-salted
+ cp $@ $@.salted
+ echo -ne $(1) >> $@.salted
+ $(STAGING_DIR_HOST)/bin/mkhash md5 $@.salted | head -c32 >> $@
+ rm $@.salted
+endef
+
define Build/append-ubi
sh $(TOPDIR)/scripts/ubinize-image.sh \
$(if $(UBOOTENV_IN_UBI),--uboot-env) \