aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 15084093d2..ff8acf96c4 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -316,6 +316,15 @@ define Build/gzip
@mv $@.new $@
endef
+define Build/gzip-filename
+ @mkdir -p $@.tmp
+ @cp $@ $@.tmp/$(word 1,$(1))
+ $(if $(SOURCE_DATE_EPOCH),touch -hcd "@$(SOURCE_DATE_EPOCH)" $@.tmp/$(word 1,$(1)) $(word 2,$(1)))
+ $(STAGING_DIR_HOST)/bin/gzip -f -9 -N -c $@.tmp/$(word 1,$(1)) $(word 2,$(1)) > $@.new
+ @mv $@.new $@
+ @rm -rf $@.tmp
+endef
+
define Build/install-dtb
$(call locked, \
$(foreach dts,$(DEVICE_DTS), \