aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 438f1e87e4..a8faefbcff 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -396,8 +396,9 @@ endef
define Build/uImage
mkimage -A $(LINUX_KARCH) \
-O linux -T kernel \
- -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' -d $@ $@.new
+ -C $(word 1,$(1)) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' \
+ $(wordlist 2,$(words $(1)),$(1)) -d $@ $@.new
mv $@.new $@
endef