aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk14
1 files changed, 11 insertions, 3 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 2d2d53cd65..376553b8d2 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -37,7 +37,11 @@ define Build/package-kernel-ubifs
endef
define Build/append-image
- dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) >> $@
+ cp "$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1)" "$@.stripmeta"
+ fwtool -s /dev/null -t "$@.stripmeta" || :
+ fwtool -i /dev/null -t "$@.stripmeta" || :
+ dd if="$@.stripmeta" >> "$@"
+ rm "$@.stripmeta"
endef
ifdef IB
@@ -46,8 +50,12 @@ define Build/append-image-stage
endef
else
define Build/append-image-stage
- dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) of=$(STAGING_DIR_IMAGE)/$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))-$(DEVICE_NAME)-$(1)
- dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) >> $@
+ cp "$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1)" "$@.stripmeta"
+ fwtool -s /dev/null -t "$@.stripmeta" || :
+ fwtool -i /dev/null -t "$@.stripmeta" || :
+ dd if="$@.stripmeta" of="$(STAGING_DIR_IMAGE)/$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))-$(DEVICE_NAME)-$(1)"
+ dd if="$@.stripmeta" >> "$@"
+ rm "$@.stripmeta"
endef
endif