aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk18
1 files changed, 9 insertions, 9 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 5f7845a6d9..a848655399 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -77,17 +77,17 @@ define Build/append-squashfs-fakeroot-be
cat $@.fakesquashfs >> $@
endef
-# append a fake/empty rootfs uImage header, to fool the bootloaders
-# rootfs integrity check
-define Build/append-uImage-fakeroot-hdr
- touch $@.fakeroot
+# append a fake/empty uImage header, to fool bootloaders rootfs integrity check
+# for example
+define Build/append-uImage-fakehdr
+ touch $@.fakehdr
$(STAGING_DIR_HOST)/bin/mkimage \
- -A $(LINUX_KARCH) -O linux -T filesystem -C none \
- -n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) fakeroot' \
- -d $@.fakeroot \
+ -A $(LINUX_KARCH) -O linux -T $(1) -C none \
+ -n '$(VERSION_DIST) fake $(1)' \
+ -d $@.fakehdr \
-s \
- $@.fakeroot
- cat $@.fakeroot >> $@
+ $@.fakehdr
+ cat $@.fakehdr >> $@
endef
define Build/tplink-safeloader