aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index aaece705d2..1ec5252972 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -102,8 +102,7 @@ define Build/tplink-safeloader
endef
define Build/append-dtb
- $(call Image/BuildDTB,$(if $(DEVICE_DTS_DIR),$(DEVICE_DTS_DIR),$(DTS_DIR))/$(DEVICE_DTS).dts,$@.dtb)
- cat $@.dtb >> $@
+ cat $(KDIR)/image-$(firstword $(DEVICE_DTS)).dtb >> $@
endef
define Build/install-dtb