aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 0f9ac0836c..5f7845a6d9 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -80,10 +80,11 @@ endef
# append a fake/empty rootfs uImage header, to fool the bootloaders
# rootfs integrity check
define Build/append-uImage-fakeroot-hdr
- rm -f $@.fakeroot
+ touch $@.fakeroot
$(STAGING_DIR_HOST)/bin/mkimage \
-A $(LINUX_KARCH) -O linux -T filesystem -C none \
-n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) fakeroot' \
+ -d $@.fakeroot \
-s \
$@.fakeroot
cat $@.fakeroot >> $@