aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 4fe8c0f456..aaece705d2 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -249,7 +249,8 @@ endef
define Build/tplink-v2-header
$(STAGING_DIR_HOST)/bin/mktplinkfw2 \
- -c -H $(TPLINK_HWID) -W $(TPLINK_HWREV) \
+ -c -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -L $(KERNEL_LOADADDR) \
+ -E $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-w $(TPLINK_HWREVADD) -F "$(TPLINK_FLASHLAYOUT)" \
-T $(TPLINK_HVERSION) -V "ver. 2.0" \
-k $@ -o $@.new $(1)