aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 04fa853fbb..e0f2918a38 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -110,6 +110,10 @@ define Build/append-rootfs
dd if=$(IMAGE_ROOTFS) >> $@
endef
+define Build/append-file
+ cat "$(1)" >> "$@"
+endef
+
define Build/append-ubi
sh $(TOPDIR)/scripts/ubinize-image.sh \
$(if $(UBOOTENV_IN_UBI),--uboot-env) \