aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 143a042fa2..05c2300886 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -264,6 +264,11 @@ define Build/openmesh-image
"$(call param_get_default,rootfs,$(1),$@)" "rootfs"
endef
+define Build/senao-header
+ $(STAGING_DIR_HOST)/bin/mksenaofw $(1) -e $@ -o $@.new
+ mv $@.new $@
+endef
+
define Build/sysupgrade-tar
sh $(TOPDIR)/scripts/sysupgrade-tar.sh \
--board $(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)) \