aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index f7e6ba6aa6..143a042fa2 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -62,6 +62,14 @@ define Build/make-ras
@mv $@.new $@
endef
+define Build/mkbuffaloimg
+ $(STAGING_DIR_HOST)/bin/mkbuffaloimg -B $(BOARDNAME) \
+ -R $$(($(subst k, * 1024,$(ROOTFS_SIZE)))) \
+ -K $$(($(subst k, * 1024,$(KERNEL_SIZE)))) \
+ -i $@ -o $@.new
+ mv $@.new $@
+endef
+
define Build/netgear-chk
$(STAGING_DIR_HOST)/bin/mkchkimg \
-o $@.new \