aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 1ba849f88d..e11e3edd09 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -136,9 +136,8 @@ Host/Exports=$(Host/Exports/Default)
.NOTPARALLEL:
ifndef DUMP
- define HostBuild
+ define HostBuild/Core
$(if $(HOST_QUILT),$(Host/Quilt))
- $(if $(if $(PKG_HOST_ONLY),,$(STAMP_PREPARED)),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
$(if $(DUMP),,$(call HostHost/Autoclean))
$(HOST_STAMP_PREPARED):
@@ -198,3 +197,8 @@ ifndef DUMP
clean:
endif
+
+define HostBuild
+ $(HostBuild/Core)
+ $(if $(if $(PKG_HOST_ONLY),,$(STAMP_PREPARED)),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
+endef