aboutsummaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/include/download.mk b/include/download.mk
index 0a12c69ebd..ec55777238 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -180,6 +180,19 @@ define Download/Defaults
OPTS:=
endef
+define Download/default
+ FILE:=$(PKG_SOURCE)
+ URL:=$(PKG_SOURCE_URL)
+ SUBDIR:=$(PKG_SOURCE_SUBDIR)
+ PROTO:=$(PKG_SOURCE_PROTO)
+ $(if $(PKG_SOURCE_MIRROR),MIRROR:=$(filter 1,$(PKG_MIRROR)))
+ $(if $(PKG_MIRROR_MD5SUM),MIRROR_MD5SUM:=$(PKG_MIRROR_MD5SUM))
+ $(if $(PKG_MIRROR_HASH),MIRROR_HASH:=$(PKG_MIRROR_HASH))
+ VERSION:=$(PKG_SOURCE_VERSION)
+ $(if $(PKG_MD5SUM),MD5SUM:=$(PKG_MD5SUM))
+ $(if $(PKG_HASH),HASH:=$(PKG_HASH))
+endef
+
define Download
$(eval $(Download/Defaults))
$(eval $(Download/$(1)))