aboutsummaryrefslogtreecommitdiffstats
path: root/include/bpf.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/bpf.mk')
-rw-r--r--include/bpf.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/bpf.mk b/include/bpf.mk
index 967de7a172..d9f1153cba 100644
--- a/include/bpf.mk
+++ b/include/bpf.mk
@@ -64,7 +64,7 @@ BPF_CFLAGS := \
-O2 -emit-llvm -Xclang -disable-llvm-passes
ifeq ($(DUMP),)
- CLANG_VER:=$(shell clang -dM -E - < /dev/null | grep __clang_major__ | cut -d' ' -f3)
+ CLANG_VER:=$(shell $(CLANG) -dM -E - < /dev/null | grep __clang_major__ | cut -d' ' -f3)
CLANG_VER_VALID:=$(shell [ "$(CLANG_VER)" -ge "$(CLANG_MIN_VER)" ] && echo 1 )
ifeq ($(CLANG_VER_VALID),)
$(error ERROR: LLVM/clang version too old. Minimum required: $(CLANG_MIN_VER), found: $(CLANG_VER))