aboutsummaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index ec67c844f7..4b48b38992 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -62,6 +62,12 @@ define patch_libtool
);
endef
+define set_libtool_abiver
+ sed -i \
+ -e 's,^soname_spec=.*,soname_spec="\\$$$${libname}\\$$$${shared_ext}.$(PKG_ABI_VERSION)",' \
+ -e 's,^library_names_spec=.*,library_names_spec="\\$$$${libname}\\$$$${shared_ext}.$(PKG_ABI_VERSION) \\$$$${libname}\\$$$${shared_ext}",' \
+ $(PKG_BUILD_DIR)/libtool
+endef
PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
PKG_AUTOMAKE_PATHS?=$(CONFIGURE_PATH)
@@ -110,6 +116,10 @@ ifneq ($(filter libtool,$(PKG_FIXUP)),)
endif
endif
+ifneq ($(filter libtool-abiver,$(PKG_FIXUP)),)
+ Hooks/Configure/Post += set_libtool_abiver
+endif
+
ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
PKG_BUILD_DEPENDS += libtool gettext libiconv
ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)