aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 3c0f927d9d..5301883061 100644
--- a/Makefile
+++ b/Makefile
@@ -79,6 +79,12 @@ endif
# check prerequisites before starting to build
prereq: $(target/stamp-prereq) tmp/.prereq_packages
+ @if [ ! -f "$(INCLUDE_DIR)/site/$(ARCH)" ]; then \
+ echo 'ERROR: Missing site config for architecture "$(ARCH)" !'; \
+ echo ' The missing file will cause configure scripts to fail during compilation.'; \
+ echo ' Please provide a "$(INCLUDE_DIR)/site/$(ARCH)" file and restart the build.'; \
+ exit 1; \
+ fi
checksum: FORCE
$(call sha256sums,$(BIN_DIR),$(CONFIG_BUILDBOT))