aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/prereq-build.mk4
-rw-r--r--include/subdir.mk1
2 files changed, 5 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 5b9a7e049d..bac5fdc84c 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -138,6 +138,10 @@ $(eval $(call SetupHostCommand,bzip2,Please install 'bzip2', \
$(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
wget --version | grep GNU))
+$(eval $(call SetupHostCommand,gtime,Please install GNU 'time', \
+ gtime --version 2>&1 | grep GNU, \
+ time --version 2>&1 | grep GNU))
+
$(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
perl --version | grep "perl.*v5"))
diff --git a/include/subdir.mk b/include/subdir.mk
index 79a80528ae..ed4f7537d5 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -43,6 +43,7 @@ log_make = \
$(if $(BUILD_LOG), \
set -o pipefail; \
mkdir -p $(BUILD_LOG_DIR)/$(1)$(if $(4),/$(4));) \
+ gtime -f "time: $(1)$(if $(4),/$(4))/$(if $(3),$(3)-)$(2)\#%U\#%S\#%e" -- \
$$(SUBMAKE) $(subdir_make_opts) $(if $(3),$(3)-)$(2) \
$(if $(BUILD_LOG),SILENT= 2>&1 | tee $(BUILD_LOG_DIR)/$(1)$(if $(4),/$(4))/$(if $(3),$(3)-)$(2).txt)