aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-sunxi/Makefile6
-rw-r--r--target/linux/sunxi/image/cortex-a8.mk10
2 files changed, 16 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 50c6b06a71..d986f6259c 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -96,6 +96,12 @@ define U-Boot/Hummingbird_A31
NAME:=Hummingbird A31 board
endef
+define U-Boot/Marsboard
+ BUILD_SUBTARGET:=cortexa8
+ NAME:=Marsboard
+ BUILD_DEVICES:=sun4i-a10-marsboard
+endef
+
define U-Boot/Mele_M9
BUILD_SUBTARGET:=cortexa7
NAME:=Mele M9 (A31)
diff --git a/target/linux/sunxi/image/cortex-a8.mk b/target/linux/sunxi/image/cortex-a8.mk
index 97e033dbb3..564a66f938 100644
--- a/target/linux/sunxi/image/cortex-a8.mk
+++ b/target/linux/sunxi/image/cortex-a8.mk
@@ -56,4 +56,14 @@ endef
TARGET_DEVICES += sun4i-a10-pcduino
+
+define Device/sun4i-a10-marsboard
+ DEVICE_TITLE:=HAOYU Electronics Marsboard A10
+ DEVICE_PACKAGES:=mod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi sound-soc-sunxi
+ SUPPORTED_DEVICES:=marsboard,a10-marsboard
+ SUNXI_DTS:=sun4i-a10-marsboard
+endef
+
+TARGET_DEVICES += sun4i-a10-marsboard
+
endif