aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/generic/patches-4.4/206-mips-disable-vdso.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch b/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch
new file mode 100644
index 0000000000..9b1346db81
--- /dev/null
+++ b/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch
@@ -0,0 +1,21 @@
+Disable MIPS VDSO until the cache issues have been sorted out.
+
+Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+
+--- a/arch/mips/vdso/Makefile
++++ b/arch/mips/vdso/Makefile
+@@ -26,11 +26,11 @@ aflags-vdso := $(ccflags-vdso) \
+ # the comments on that file.
+ #
+ ifndef CONFIG_CPU_MIPSR6
+- ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
+- $(warning MIPS VDSO requires binutils >= 2.25)
++# ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
++# $(warning MIPS VDSO requires binutils >= 2.25)
+ obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
+ ccflags-vdso += -DDISABLE_MIPS_VDSO
+- endif
++# endif
+ endif
+
+ # VDSO linker flags.