aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/prereq-build.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 80d549af39..7428c21e16 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -53,6 +53,13 @@ $(eval $(call TestHostCommand,ncurses, \
Please install ncurses. (Missing libncurses.so or ncurses.h), \
echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
+
+$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
+ git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule, \
+ git submodule --help | grep -- --recursive))
+
+$(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
+ rsync --version </dev/null))
endif # IB
ifeq ($(HOST_OS),Linux)
@@ -181,16 +188,9 @@ $(eval $(call TestHostCommand,python3-distutils, \
Please install the Python3 distutils module, \
$(STAGING_DIR_HOST)/bin/python3 -c 'import distutils'))
-$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
- git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule, \
- git submodule --help | grep -- --recursive))
-
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))
-$(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
- rsync --version </dev/null))
-
$(eval $(call SetupHostCommand,which,Please install 'which', \
/usr/bin/which which, \
/bin/which which, \