aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ramips/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 0992d6ba9f..275251ff6b 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -213,7 +213,15 @@ endef
define Device/uimage-lzma-loader
LOADER_TYPE := bin
- KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | uImage none
+ KERNEL/lzma-loader := kernel-bin | append-dtb | lzma | loader-kernel
+ KERNEL := $$(KERNEL/lzma-loader) | uImage none
+endef
+
+define Device/seama-lzma-loader
+ $(Device/seama)
+ $(Device/uimage-lzma-loader)
+ KERNEL := $$(KERNEL/lzma-loader) | relocate-kernel | lzma -a0
+ KERNEL_INITRAMFS := $$(KERNEL/lzma-loader) | uImage none
endef
include $(SUBTARGET).mk