aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--toolchain/gcc/common.mk8
-rw-r--r--toolchain/gcc/final/Makefile2
2 files changed, 5 insertions, 5 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index ea2e2634b6..7eae855eea 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -72,7 +72,7 @@ ifdef CONFIG_INSTALL_GCCGO
endif
ifdef CONFIG_GCC_USE_GRAPHITE
- GRAPHITE_CONFIGURE:= --with-isl=$(TOPDIR)/staging_dir/host
+ GRAPHITE_CONFIGURE:= --with-isl=$(STAGING_DIR_HOST)
else
GRAPHITE_CONFIGURE:= --without-isl --without-cloog
endif
@@ -106,9 +106,9 @@ GCC_CONFIGURE:= \
--with-abi=$(call qstrip,$(CONFIG_MIPS64_ABI))) \
$(if $(CONFIG_arc),--with-cpu=$(CONFIG_CPU_TYPE)) \
$(if $(CONFIG_powerpc64), $(if $(CONFIG_USE_MUSL),--with-abi=elfv2)) \
- --with-gmp=$(TOPDIR)/staging_dir/host \
- --with-mpfr=$(TOPDIR)/staging_dir/host \
- --with-mpc=$(TOPDIR)/staging_dir/host \
+ --with-gmp=$(STAGING_DIR_HOST) \
+ --with-mpfr=$(STAGING_DIR_HOST) \
+ --with-mpc=$(STAGING_DIR_HOST) \
--disable-decimal-float \
--with-diagnostics-color=auto-if-env \
--enable-__cxa_atexit \
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 0315b9d1f1..049ddf61f0 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -9,7 +9,7 @@ GCC_CONFIGURE += \
--enable-threads \
--with-slibdir=$(TOOLCHAIN_DIR)/lib \
--enable-lto \
- --with-libelf=$(TOPDIR)/staging_dir/host
+ --with-libelf=$(STAGING_DIR_HOST)
ifndef CONFIG_USE_GLIBC
GCC_CONFIGURE += --disable-libsanitizer