aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-kernel.in16
-rw-r--r--package/kernel/broadcom-wl/Makefile2
-rw-r--r--package/kernel/mac80211/Makefile1
-rw-r--r--package/network/services/hostapd/Config.in1
-rw-r--r--target/linux/generic/config-5.1010
-rw-r--r--target/linux/generic/config-5.1510
6 files changed, 28 insertions, 12 deletions
diff --git a/config/Config-kernel.in b/config/Config-kernel.in
index f1ee919ee3..34c606a848 100644
--- a/config/Config-kernel.in
+++ b/config/Config-kernel.in
@@ -1108,6 +1108,22 @@ config KERNEL_NET_L3_MASTER_DEV
This module provides glue between core networking code and device
drivers to support L3 master devices like VRF.
+config KERNEL_WIRELESS_EXT
+ def_bool n
+
+config KERNEL_WEXT_CORE
+ def_bool KERNEL_WIRELESS_EXT
+
+config KERNEL_WEXT_PRIV
+ def_bool KERNEL_WIRELESS_EXT
+
+config KERNEL_WEXT_PROC
+ def_bool KERNEL_WIRELESS_EXT
+
+config KERNEL_WEXT_SPY
+ def_bool KERNEL_WIRELESS_EXT
+
+
#
# NFS related symbols
#
diff --git a/package/kernel/broadcom-wl/Makefile b/package/kernel/broadcom-wl/Makefile
index 7188c4900e..dec5bcb98d 100644
--- a/package/kernel/broadcom-wl/Makefile
+++ b/package/kernel/broadcom-wl/Makefile
@@ -40,7 +40,7 @@ endef
define KernelPackage/brcm-wl/Default
$(call Package/broadcom-wl/Default)
SECTION:=kernel
- DEPENDS:=@(TARGET_bcm47xx||TARGET_bcm63xx) +wireless-tools
+ DEPENDS:=@(TARGET_bcm47xx||TARGET_bcm63xx) +wireless-tools +@KERNEL_WIRELESS_EXT
TITLE:=Kernel driver for BCM43xx chipsets
FILES:=$(PKG_BUILD_DIR)/driver$(1)/wl.ko $(PKG_BUILD_DIR)/glue/wl_glue.ko
AUTOLOAD:=$(call AutoProbe,wl)
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index d467d20c61..f68488a24a 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -56,7 +56,6 @@ config_package=$(if $(CONFIG_PACKAGE_kmod-$(1)),m)
config-y:= \
WLAN \
- CFG80211_WEXT \
CFG80211_CERTIFICATION_ONUS \
MAC80211_RC_MINSTREL \
MAC80211_RC_MINSTREL_HT \
diff --git a/package/network/services/hostapd/Config.in b/package/network/services/hostapd/Config.in
index 4cfcaafade..21ed42fa07 100644
--- a/package/network/services/hostapd/Config.in
+++ b/package/network/services/hostapd/Config.in
@@ -65,6 +65,7 @@ config WPA_WOLFSSL
config DRIVER_WEXT_SUPPORT
bool
+ select KERNEL_WIRELESS_EXT
default n
config DRIVER_11N_SUPPORT
diff --git a/target/linux/generic/config-5.10 b/target/linux/generic/config-5.10
index 281607bdbb..07edd53ff9 100644
--- a/target/linux/generic/config-5.10
+++ b/target/linux/generic/config-5.10
@@ -7085,15 +7085,15 @@ CONFIG_WATCHDOG_OPEN_TIMEOUT=0
# CONFIG_WD80x3 is not set
# CONFIG_WDAT_WDT is not set
# CONFIG_WDTPCI is not set
-CONFIG_WEXT_CORE=y
-CONFIG_WEXT_PRIV=y
-CONFIG_WEXT_PROC=y
-CONFIG_WEXT_SPY=y
+# CONFIG_WEXT_CORE is not set
+# CONFIG_WEXT_PRIV is not set
+# CONFIG_WEXT_PROC is not set
+# CONFIG_WEXT_SPY is not set
CONFIG_WILINK_PLATFORM_DATA=y
# CONFIG_WIMAX is not set
# CONFIG_WIREGUARD is not set
CONFIG_WIRELESS=y
-CONFIG_WIRELESS_EXT=y
+# CONFIG_WIRELESS_EXT is not set
# CONFIG_WIRELESS_WDS is not set
# CONFIG_WIZNET_W5100 is not set
# CONFIG_WIZNET_W5300 is not set
diff --git a/target/linux/generic/config-5.15 b/target/linux/generic/config-5.15
index 8c6a3f641e..8901a483dd 100644
--- a/target/linux/generic/config-5.15
+++ b/target/linux/generic/config-5.15
@@ -7419,15 +7419,15 @@ CONFIG_WATCHDOG_OPEN_TIMEOUT=0
# CONFIG_WDAT_WDT is not set
# CONFIG_WDTPCI is not set
# CONFIG_WERROR is not set
-CONFIG_WEXT_CORE=y
-CONFIG_WEXT_PRIV=y
-CONFIG_WEXT_PROC=y
-CONFIG_WEXT_SPY=y
+# CONFIG_WEXT_CORE is not set
+# CONFIG_WEXT_PRIV is not set
+# CONFIG_WEXT_PROC is not set
+# CONFIG_WEXT_SPY is not set
CONFIG_WILINK_PLATFORM_DATA=y
# CONFIG_WIMAX is not set
# CONFIG_WIREGUARD is not set
CONFIG_WIRELESS=y
-CONFIG_WIRELESS_EXT=y
+# CONFIG_WIRELESS_EXT is not set
# CONFIG_WIRELESS_WDS is not set
# CONFIG_WIZNET_W5100 is not set
# CONFIG_WIZNET_W5300 is not set