aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/virt.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/virt.mk b/package/kernel/linux/modules/virt.mk
index 90226b4806..1d9caa9bc8 100644
--- a/package/kernel/linux/modules/virt.mk
+++ b/package/kernel/linux/modules/virt.mk
@@ -117,3 +117,27 @@ define KernelPackage/vfio-pci/description
endef
$(eval $(call KernelPackage,vfio-pci))
+
+
+define KernelPackage/vhost
+ SUBMENU:=Virtualization
+ TITLE:=Host kernel accelerator for virtio (base)
+ KCONFIG:=CONFIG_VHOST
+ FILES:=$(LINUX_DIR)/drivers/vhost/vhost.ko \
+ $(LINUX_DIR)/drivers/vhost/vhost_iotlb.ko
+ AUTOLOAD:=$(call AutoProbe,vhost vhost_iotlb)
+endef
+
+$(eval $(call KernelPackage,vhost))
+
+
+define KernelPackage/vhost-net
+ SUBMENU:=Virtualization
+ TITLE:=Host kernel accelerator for virtio-net
+ DEPENDS:=+kmod-tun +kmod-vhost
+ KCONFIG:=CONFIG_VHOST_NET
+ FILES:=$(LINUX_DIR)/drivers/vhost/vhost_net.ko
+ AUTOLOAD:=$(call AutoProbe,vhost_net)
+endef
+
+$(eval $(call KernelPackage,vhost-net))