aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--toolchain/gcc/common.mk2
-rw-r--r--toolchain/gcc/final/Makefile1
2 files changed, 3 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 7eae855eea..5f314c7fc0 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -106,6 +106,8 @@ GCC_CONFIGURE:= \
--with-abi=$(call qstrip,$(CONFIG_MIPS64_ABI))) \
$(if $(CONFIG_arc),--with-cpu=$(CONFIG_CPU_TYPE)) \
$(if $(CONFIG_powerpc64), $(if $(CONFIG_USE_MUSL),--with-abi=elfv2)) \
+ --with-system-zlib=$(STAGING_DIR_HOST) \
+ --without-zstd \
--with-gmp=$(STAGING_DIR_HOST) \
--with-mpfr=$(STAGING_DIR_HOST) \
--with-mpc=$(STAGING_DIR_HOST) \
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 049ddf61f0..78a5576bff 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -8,6 +8,7 @@ GCC_CONFIGURE += \
--enable-shared \
--enable-threads \
--with-slibdir=$(TOOLCHAIN_DIR)/lib \
+ --enable-plugins \
--enable-lto \
--with-libelf=$(STAGING_DIR_HOST)