aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/crypto.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 35113e12d0..f8af5f0a3b 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -239,6 +239,18 @@ endef
$(eval $(call KernelPackage,crypto-echainiv))
+define KernelPackage/crypto-essiv
+ TITLE:=ESSIV support for block encryption
+ DEPENDS:=+kmod-crypto-authenc
+ KCONFIG:=CONFIG_CRYPTO_ESSIV
+ FILES:= $(LINUX_DIR)/crypto/essiv.ko
+ AUTOLOAD:=$(call AutoLoad,10,essiv)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-essiv))
+
+
define KernelPackage/crypto-fcrypt
TITLE:=FCRYPT cipher CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_FCRYPT