aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/libs/libnl/Makefile6
-rw-r--r--package/libs/libnl/patches/100-build-add-Libs.private-field-in-libnl-pkg-config-file.patch25
2 files changed, 3 insertions, 28 deletions
diff --git a/package/libs/libnl/Makefile b/package/libs/libnl/Makefile
index 7117226d50..b6eae82651 100644
--- a/package/libs/libnl/Makefile
+++ b/package/libs/libnl/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libnl
-PKG_VERSION:=3.5.0
-PKG_RELEASE:=2
+PKG_VERSION:=3.6.0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/thom311/libnl/releases/download/libnl$(subst .,_,$(PKG_VERSION))
-PKG_HASH:=352133ec9545da76f77e70ccb48c9d7e5324d67f6474744647a7ed382b5e05fa
+PKG_HASH:=532155fd011e5a805bd67121b87a01c757e2bb24112ac17e69cb86013b970009
PKG_LICENSE:=LGPL-2.1
PKG_LICENSE_FILES:=COPYING
diff --git a/package/libs/libnl/patches/100-build-add-Libs.private-field-in-libnl-pkg-config-file.patch b/package/libs/libnl/patches/100-build-add-Libs.private-field-in-libnl-pkg-config-file.patch
deleted file mode 100644
index cec720b8e8..0000000000
--- a/package/libs/libnl/patches/100-build-add-Libs.private-field-in-libnl-pkg-config-file.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From db0d59cd06f3ffd350379847c0885e1bfb85af0f Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Sat, 7 Mar 2015 11:34:42 +0100
-Subject: [PATCH 2/2] build: add Libs.private field in libnl pkg-config file
-
-In order to support static linking, the libnl pkg-config file should
-indicate in its Libs.private field the libraries that libnl-3.0.a
-requires. The LIBS variable contains the appropriate list of
-libraries: -lm in all cases, and -lpthread when pthread support is
-enabled. This allows to statically link applications against libnl
-properly.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- libnl-3.0.pc.in | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/libnl-3.0.pc.in
-+++ b/libnl-3.0.pc.in
-@@ -7,4 +7,5 @@ Name: libnl
- Description: Convenience library for netlink sockets
- Version: @PACKAGE_VERSION@
- Libs: -L${libdir} -lnl-@MAJ_VERSION@
-+Libs.private: @LIBS@
- Cflags: -I${includedir}/libnl@MAJ_VERSION@