aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/lib.mk4
-rw-r--r--package/kernel/linux/modules/other.mk4
-rw-r--r--target/linux/generic/config-5.151
3 files changed, 8 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index 81ceb1f76c..d4d44ad8f0 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -152,13 +152,15 @@ define KernelPackage/lib-lz4
DEPENDS:=+kmod-crypto-acompress
KCONFIG:= \
CONFIG_CRYPTO_LZ4 \
+ CONFIG_CRYPTO_LZ4HC \
CONFIG_LZ4_COMPRESS \
CONFIG_LZ4_DECOMPRESS
FILES:= \
$(LINUX_DIR)/crypto/lz4.ko \
$(LINUX_DIR)/lib/lz4/lz4_compress.ko \
+ $(LINUX_DIR)/lib/lz4/lz4hc_compress.ko \
$(LINUX_DIR)/lib/lz4/lz4_decompress.ko
- AUTOLOAD:=$(call AutoProbe,lz4 lz4_compress lz4_decompress)
+ AUTOLOAD:=$(call AutoProbe,lz4 lz4_compress lz4hc_compress lz4_decompress)
endef
define KernelPackage/lib-lz4/description
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 58dd2d6c25..c5f944ed31 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1010,6 +1010,10 @@ define KernelPackage/zram/config
bool "lz4"
select PACKAGE_kmod-lib-lz4
+ config ZRAM_DEF_COMP_LZ4HC
+ bool "lz4-hc"
+ select PACKAGE_kmod-lib-lz4hc
+
config ZRAM_DEF_COMP_ZSTD
bool "zstd"
select PACKAGE_kmod-lib-zstd
diff --git a/target/linux/generic/config-5.15 b/target/linux/generic/config-5.15
index b3541ab95b..52aba2fa0e 100644
--- a/target/linux/generic/config-5.15
+++ b/target/linux/generic/config-5.15
@@ -7547,6 +7547,7 @@ CONFIG_ZONE_DMA=y
# CONFIG_ZPOOL is not set
# CONFIG_ZRAM is not set
# CONFIG_ZRAM_DEF_COMP_LZ4 is not set
+# CONFIG_ZRAM_DEF_COMP_LZ4HC is not set
# CONFIG_ZRAM_DEF_COMP_LZO is not set
# CONFIG_ZRAM_DEF_COMP_LZORLE is not set
# CONFIG_ZRAM_DEF_COMP_ZSTD is not set