aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/realtek/image/Makefile14
-rw-r--r--target/linux/realtek/image/common.mk6
2 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index a2afb39d40..f50821d24a 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -9,8 +9,8 @@ DEVICE_VARS += \
CAMEO_BOARD_VERSION \
CAMEO_CUSTOMER_SIGNATURE \
CAMEO_KERNEL_PART \
+ CAMEO_KERNEL_PART_SIZE \
CAMEO_ROOTFS_PART \
- DLINK_KERNEL_PART_SIZE \
H3C_DEVICE_ID \
H3C_PRODUCT_ID \
ZYXEL_VERS
@@ -23,18 +23,18 @@ define Build/zyxel-vers
done ) >> $@
endef
-define Build/dlink-cameo
- $(SCRIPT_DIR)/cameo-tag.py $@ $(DLINK_KERNEL_PART_SIZE)
+define Build/cameo-tag
+ $(SCRIPT_DIR)/cameo-tag.py $@ $(CAMEO_KERNEL_PART_SIZE)
endef
-define Build/dlink-version
+define Build/cameo-version
echo -n "OpenWrt" >> $@
dd if=/dev/zero bs=25 count=1 >> $@
endef
-define Build/dlink-headers
- dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) count=1 of=$@.kernel_part; \
- dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) skip=1 of=$@.rootfs_part; \
+define Build/cameo-headers
+ dd if=$@ bs=$(CAMEO_KERNEL_PART_SIZE) count=1 of=$@.kernel_part; \
+ dd if=$@ bs=$(CAMEO_KERNEL_PART_SIZE) skip=1 of=$@.rootfs_part; \
$(SCRIPT_DIR)/cameo-imghdr.py $@.kernel_part $@.kernel_part.hex \
"$(DEVICE_MODEL)" os $(CAMEO_KERNEL_PART) \
$(CAMEO_CUSTOMER_SIGNATURE) \
diff --git a/target/linux/realtek/image/common.mk b/target/linux/realtek/image/common.mk
index 214683f8e9..1a1d6356a7 100644
--- a/target/linux/realtek/image/common.mk
+++ b/target/linux/realtek/image/common.mk
@@ -9,7 +9,7 @@ define Device/d-link_dgs-1210
append-dtb | \
libdeflate-gzip | \
uImage gzip | \
- dlink-cameo
+ cameo-tag
CAMEO_KERNEL_PART := 2
CAMEO_ROOTFS_PART := 3
CAMEO_CUSTOMER_SIGNATURE := 2
@@ -22,8 +22,8 @@ define Device/d-link_dgs-1210
pad-rootfs | \
pad-to 16 | \
check-size | \
- dlink-version | \
- dlink-headers
+ cameo-version | \
+ cameo-headers
endef
define Device/hpe_1920